# CVE-2016-10551: SQL Injection in waterline-sequel

> Attackers can inject SQL via user input in waterline-sequel, gaining full database access. Developers using this Node.js module should upgrade.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-cgpp-wm2h-6hqx

## What is CVE-2016-10551?

CVE-2016-10551 is a critical SQL injection vulnerability in HackerOne waterline-sequel node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

waterline-sequel is a module that helps generate SQL statements for Waterline apps Any user input that goes into Waterline's `like`, `contains`, `startsWith`, or `endsWith` will end up in waterline-sequel with the potential for malicious code. A malicious user can input their own SQL statements in waterline-sequel 0.50 that will get executed and have full access to the database.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-10551?

2 open source packages ship an affected version, including waterline-sequel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `waterline-sequel` | npm | All versions | 0.5.1 |
| `waterline-sequel` | npm | All versions | 0.5.1 |

Products: Balderdash Waterline-Sequel.

## How do I fix CVE-2016-10551?

Upgrade waterline-sequel to 0.5.1 or later.

## Is CVE-2016-10551 being exploited?

There is no known exploitation of CVE-2016-10551 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10551 and fix it if it is affected.

What it is: CVE-2016-10551 is a critical SQL injection vulnerability in HackerOne waterline-sequel node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10551 in the wild and no public exploit code.

Affected packages and fixed versions:
- waterline-sequel (npm): affected all versions; fixed in 0.5.1
- waterline-sequel (npm): affected all versions; fixed in 0.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10551/ (Markdown: https://insights.sbomify.com/CVE-2016-10551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10551
- OSV: https://osv.dev/vulnerability/CVE-2016-10551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10551/
Summaries are generated and may contain mistakes; the official description above is the record.
