# CVE-2016-10557: appium-chromedriver downloads Resources over HTTP

> Attackers can execute remote code by intercepting HTTP downloads of the Chromedriver binary in the appium-chromedriver Node.js module.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-hc94-2wfr-4pwf

## What is CVE-2016-10557?

CVE-2016-10557 is a high-severity vulnerability in HackerOne appium-chromedriver node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

appium-chromedriver is a Node.js wrapper around Chromedriver. Versions below 2.9.4 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10557?

2 open source packages ship an affected version, including appium-chromedriver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `appium-chromedriver` | npm | All versions | 2.9.4 |
| `appium-chromedriver` | npm | All versions | 2.9.4 |

Products: Appium Appium-Chromedriver.

## How do I fix CVE-2016-10557?

Upgrade appium-chromedriver to 2.9.4 or later.

## Is CVE-2016-10557 being exploited?

There is no known exploitation of CVE-2016-10557 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10557 and fix it if it is affected.

What it is: CVE-2016-10557 is a high-severity vulnerability in HackerOne appium-chromedriver node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10557 in the wild and no public exploit code.

Affected packages and fixed versions:
- appium-chromedriver (npm): affected all versions; fixed in 2.9.4
- appium-chromedriver (npm): affected all versions; fixed in 2.9.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10557/ (Markdown: https://insights.sbomify.com/CVE-2016-10557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10557
- OSV: https://osv.dev/vulnerability/CVE-2016-10557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10557/
Summaries are generated and may contain mistakes; the official description above is the record.
