{"answers":{"affected":"2 open source packages ship an affected version, including galenframework-cli. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10560 in the wild and no public exploit code.","fix":"Upgrade galenframework-cli to 2.3.1 or later.","what":"CVE-2016-10560 is a high-severity vulnerability in HackerOne galenframework-cli node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10560 and fix it if it is affected.\n\nWhat it is: CVE-2016-10560 is a high-severity vulnerability in HackerOne galenframework-cli node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10560 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- galenframework-cli (npm): affected all versions; fixed in 2.3.1\n- galenframework-cli (npm): affected all versions; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10560/ (Markdown: https://insights.sbomify.com/CVE-2016-10560/index.md)","id":"CVE-2016-10560","markdown":"https://insights.sbomify.com/CVE-2016-10560/index.md","name":"CVE-2016-10560","record":{"aliases":["GHSA-x5ph-4fr4-g7fw"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Galen Framework CLI","requires_auth":"none","summary":"Attackers can execute arbitrary code by intercepting HTTP downloads of binary resources in the Galen Framework CLI.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"galenframework-cli","vendor":"galenframework"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-310","name":null},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"galenframework-cli is the node wrapper for the Galen Framework. galenframework-cli below 2.3.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Downloads Resources over HTTP in galenframework-cli","id":"CVE-2016-10560","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Directory Traversal in bitty","id":"CVE-2016-10561"},"packages":[{"ecosystem":"npm","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"galenframework-cli","purl":null,"source":"GHSA-x5ph-4fr4-g7fw"},{"ecosystem":"npm","fixed":["2.3.1"],"introduced":["0"],"last_affected":[],"package":"galenframework-cli","purl":"pkg:npm/galenframework-cli","source":"GHSA-x5ph-4fr4-g7fw"}],"prev":{"headline":"Downloads Resources over HTTP in selenium-download","id":"CVE-2016-10559"},"products":["galenframework-cli node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary code by intercepting HTTP downloads of binary resources in the Galen Framework CLI.","url":"https://insights.sbomify.com/CVE-2016-10560/"}