{"answers":{"affected":"2 open source packages ship an affected version, including go-ipfs-dep. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10563 in the wild and no public exploit code.","fix":"Upgrade go-ipfs-dep to 0.4.4 or later.","what":"CVE-2016-10563 is a high-severity vulnerability in HackerOne go-ipfs-dep node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10563 and fix it if it is affected.\n\nWhat it is: CVE-2016-10563 is a high-severity vulnerability in HackerOne go-ipfs-dep node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10563 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- go-ipfs-dep (npm): affected all versions; fixed in 0.4.4\n- go-ipfs-dep (npm): affected all versions; fixed in 0.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10563/ (Markdown: https://insights.sbomify.com/CVE-2016-10563/index.md)","id":"CVE-2016-10563","markdown":"https://insights.sbomify.com/CVE-2016-10563/index.md","name":"CVE-2016-10563","record":{"aliases":["GHSA-g3xp-v2ff-x5c3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Go IPFS dependency","requires_auth":"none","summary":"Insecure HTTP downloads during installation allow MITM attackers to compromise module integrity and potentially execute code.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"go-ipfs-dep","vendor":"ipfs"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-310","name":null},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"During the installation process, the go-ipfs-deps module before 0.4.4 insecurely downloads resources over HTTP. This allows for a MITM attack to compromise the integrity of the resources used by this module and could allow for further compromise.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Downloads Resources over HTTP in go-ipfs-dep","id":"CVE-2016-10563","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Downloads Resources over HTTP in apk-parser","id":"CVE-2016-10564"},"packages":[{"ecosystem":"npm","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"go-ipfs-dep","purl":null,"source":"GHSA-g3xp-v2ff-x5c3"},{"ecosystem":"npm","fixed":["0.4.4"],"introduced":["0"],"last_affected":[],"package":"go-ipfs-dep","purl":"pkg:npm/go-ipfs-dep","source":"GHSA-g3xp-v2ff-x5c3"}],"prev":{"headline":"Downloads Resources over HTTP in iedriver","id":"CVE-2016-10562"},"products":["go-ipfs-dep node module"],"published":"2018-05-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Insecure HTTP downloads during installation allow MITM attackers to compromise module integrity and potentially execute code.","url":"https://insights.sbomify.com/CVE-2016-10563/"}