# CVE-2016-10563: Downloads Resources over HTTP in go-ipfs-dep

> Insecure HTTP downloads during installation allow MITM attackers to compromise module integrity and potentially execute code.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-g3xp-v2ff-x5c3

## What is CVE-2016-10563?

CVE-2016-10563 is a high-severity vulnerability in HackerOne go-ipfs-dep node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

During the installation process, the go-ipfs-deps module before 0.4.4 insecurely downloads resources over HTTP. This allows for a MITM attack to compromise the integrity of the resources used by this module and could allow for further compromise.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10563?

2 open source packages ship an affected version, including go-ipfs-dep. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go-ipfs-dep` | npm | All versions | 0.4.4 |
| `go-ipfs-dep` | npm | All versions | 0.4.4 |

Products: Ipfs Go-Ipfs-Dep.

## How do I fix CVE-2016-10563?

Upgrade go-ipfs-dep to 0.4.4 or later.

## Is CVE-2016-10563 being exploited?

There is no known exploitation of CVE-2016-10563 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10563 and fix it if it is affected.

What it is: CVE-2016-10563 is a high-severity vulnerability in HackerOne go-ipfs-dep node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10563 in the wild and no public exploit code.

Affected packages and fixed versions:
- go-ipfs-dep (npm): affected all versions; fixed in 0.4.4
- go-ipfs-dep (npm): affected all versions; fixed in 0.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10563/ (Markdown: https://insights.sbomify.com/CVE-2016-10563/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10563
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10563
- OSV: https://osv.dev/vulnerability/CVE-2016-10563

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10563/
Summaries are generated and may contain mistakes; the official description above is the record.
