# CVE-2016-10566: install-nw downloads Resources over HTTP

> Attackers can execute remote code by intercepting HTTP downloads of NW.js binaries in the install-nw npm module.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-wq7q-7vfh-2x3h

## What is CVE-2016-10566?

CVE-2016-10566 is a high-severity vulnerability in HackerOne install-nw node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

install-nw is a module which quickly and robustly installs and caches NW.js. install-nw versions below 1.1.5 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10566?

2 open source packages ship an affected version, including install-nw. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `install-nw` | npm | All versions | 1.1.5 |
| `install-nw` | npm | All versions | 1.1.5 |

Products: Install-Nw Project Install-Nw.

## How do I fix CVE-2016-10566?

Upgrade install-nw to 1.1.5 or later.

## Is CVE-2016-10566 being exploited?

There is no known exploitation of CVE-2016-10566 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10566 and fix it if it is affected.

What it is: CVE-2016-10566 is a high-severity vulnerability in HackerOne install-nw node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10566 in the wild and no public exploit code.

Affected packages and fixed versions:
- install-nw (npm): affected all versions; fixed in 1.1.5
- install-nw (npm): affected all versions; fixed in 1.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10566/ (Markdown: https://insights.sbomify.com/CVE-2016-10566/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10566
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10566
- OSV: https://osv.dev/vulnerability/CVE-2016-10566

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10566/
Summaries are generated and may contain mistakes; the official description above is the record.
