{"answers":{"affected":"2 open source packages ship an affected version, including geoip-lite-country. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10568 in the wild and no public exploit code.","fix":"Upgrade geoip-lite-country to 1.1.4 or later.","what":"CVE-2016-10568 is a high-severity vulnerability in HackerOne geoip-lite-country node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10568 and fix it if it is affected.\n\nWhat it is: CVE-2016-10568 is a high-severity vulnerability in HackerOne geoip-lite-country node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10568 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- geoip-lite-country (npm): affected all versions; fixed in 1.1.4\n- geoip-lite-country (npm): affected all versions; fixed in 1.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10568/ (Markdown: https://insights.sbomify.com/CVE-2016-10568/index.md)","id":"CVE-2016-10568","markdown":"https://insights.sbomify.com/CVE-2016-10568/index.md","name":"CVE-2016-10568","record":{"aliases":["GHSA-ff29-f57w-2mm3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js geoip library","requires_auth":"none","summary":"Attackers can intercept unencrypted HTTP data downloads, potentially altering geolocation results or exposing sensitive information.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"geoip-lite-country","vendor":"geoip-lite-country_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-310","name":null},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"geoip-lite-country is a stripped down version of geoip-lite, supporting only country lookup. geoip-lite-country before 1.1.4 downloads data resources over HTTP, which leaves it vulnerable to MITM attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Downloads Resources over HTTP in geoip-lite-country","id":"CVE-2016-10568","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Downloads Resources over HTTP in embedza","id":"CVE-2016-10569"},"packages":[{"ecosystem":"npm","fixed":["1.1.4"],"introduced":["0"],"last_affected":[],"package":"geoip-lite-country","purl":null,"source":"GHSA-ff29-f57w-2mm3"},{"ecosystem":"npm","fixed":["1.1.4"],"introduced":["0"],"last_affected":[],"package":"geoip-lite-country","purl":"pkg:npm/geoip-lite-country","source":"GHSA-ff29-f57w-2mm3"}],"prev":{"headline":"Downloads Resources over HTTP in product-monitor","id":"CVE-2016-10567"},"products":["geoip-lite-country node module"],"published":"2018-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can intercept unencrypted HTTP data downloads, potentially altering geolocation results or exposing sensitive information.","url":"https://insights.sbomify.com/CVE-2016-10568/"}