{"answers":{"affected":"2 open source packages ship an affected version, including pngcrush-installer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10570 in the wild and no public exploit code.","fix":"Upgrade pngcrush-installer to 1.8.10 or later.","what":"CVE-2016-10570 is a high-severity vulnerability in HackerOne pngcrush-installer node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10570 and fix it if it is affected.\n\nWhat it is: CVE-2016-10570 is a high-severity vulnerability in HackerOne pngcrush-installer node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10570 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pngcrush-installer (npm): affected all versions; fixed in 1.8.10\n- pngcrush-installer (npm): affected all versions; fixed in 1.8.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10570/ (Markdown: https://insights.sbomify.com/CVE-2016-10570/index.md)","id":"CVE-2016-10570","markdown":"https://insights.sbomify.com/CVE-2016-10570/index.md","name":"CVE-2016-10570","record":{"aliases":["GHSA-g93h-75m9-3qq4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm installer module","requires_auth":"none","summary":"An attacker can execute arbitrary code by intercepting HTTP downloads of binaries during installation, affecting users of the pngcrush-installer npm module.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"pngcrush-installer","vendor":"pngcrush-installer_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-310","name":null},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"pngcrush-installer is an installer for Pngcrush. pngcrush-installer versions below 1.8.10 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pngcrush-installer downloads Resources over HTTP","id":"CVE-2016-10570","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Downloads Resources over HTTP in bkjs-wand","id":"CVE-2016-10571"},"packages":[{"ecosystem":"npm","fixed":["1.8.10"],"introduced":["0"],"last_affected":[],"package":"pngcrush-installer","purl":null,"source":"GHSA-g93h-75m9-3qq4"},{"ecosystem":"npm","fixed":["1.8.10"],"introduced":["0"],"last_affected":[],"package":"pngcrush-installer","purl":"pkg:npm/pngcrush-installer","source":"GHSA-g93h-75m9-3qq4"}],"prev":{"headline":"Downloads Resources over HTTP in embedza","id":"CVE-2016-10569"},"products":["pngcrush-installer node module"],"published":"2018-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An attacker can execute arbitrary code by intercepting HTTP downloads of binaries during installation, affecting users of the pngcrush-installer npm module.","url":"https://insights.sbomify.com/CVE-2016-10570/"}