# CVE-2016-10571: Downloads Resources over HTTP in bkjs-wand

> Attackers can execute remote code by intercepting HTTP binary downloads in bkjs-wand, requiring an upgrade to secure the supply chain.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4wm5-q7wv-6jx3

## What is CVE-2016-10571?

CVE-2016-10571 is a high-severity vulnerability in HackerOne bkjs-wand node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

bkjs-wand is imagemagick wand support for node.js and backendjs bkjs-wand versions lower than 0.3.2 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10571?

2 open source packages ship an affected version, including bkjs-wand. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bkjs-wand` | npm | All versions | 0.3.2 |
| `bkjs-wand` | npm | All versions | 0.3.2 |

Products: Bkjs-Wand Project Bkjs-Wand.

## How do I fix CVE-2016-10571?

Upgrade bkjs-wand to 0.3.2 or later.

## Is CVE-2016-10571 being exploited?

There is no known exploitation of CVE-2016-10571 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10571 and fix it if it is affected.

What it is: CVE-2016-10571 is a high-severity vulnerability in HackerOne bkjs-wand node module, published on 31 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10571 in the wild and no public exploit code.

Affected packages and fixed versions:
- bkjs-wand (npm): affected all versions; fixed in 0.3.2
- bkjs-wand (npm): affected all versions; fixed in 0.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10571/ (Markdown: https://insights.sbomify.com/CVE-2016-10571/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10571
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10571
- OSV: https://osv.dev/vulnerability/CVE-2016-10571

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10571/
Summaries are generated and may contain mistakes; the official description above is the record.
