# CVE-2016-10573: Downloads Resources over HTTP in baryton-saxophone


- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6pwf-whc8-hjf6

## What is CVE-2016-10573?

CVE-2016-10573 is a high-severity vulnerability in HackerOne baryton-saxophone node module, published on 29 May 2018. 

### Official description

baryton-saxophone is a module to install and launch Selenium Server for Mac, Linux and Windows. baryton-saxophone versions below 3.0.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10573?

2 open source packages ship an affected version, including baryton-saxophone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `baryton-saxophone` | npm | All versions | 3.0.1 |
| `baryton-saxophone` | npm | All versions | 3.0.1 |

Products: Baryton-Saxophone Project Baryton-Saxophone.

## How do I fix CVE-2016-10573?

Upgrade baryton-saxophone to 3.0.1 or later.

## Is CVE-2016-10573 being exploited?

There is no known exploitation of CVE-2016-10573 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10573 and fix it if it is affected.

What it is: CVE-2016-10573 is a high-severity vulnerability in HackerOne baryton-saxophone node module, published on 29 May 2018. 
Exploitation: There is no known exploitation of CVE-2016-10573 in the wild and no public exploit code.

Affected packages and fixed versions:
- baryton-saxophone (npm): affected all versions; fixed in 3.0.1
- baryton-saxophone (npm): affected all versions; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10573/ (Markdown: https://insights.sbomify.com/CVE-2016-10573/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10573
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10573
- OSV: https://osv.dev/vulnerability/CVE-2016-10573

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10573/
Summaries are generated and may contain mistakes; the official description above is the record.
