# CVE-2016-10575: Downloads Resources over HTTP in kindlegen


- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-h7pc-85cg-wmch

## What is CVE-2016-10575?

CVE-2016-10575 is a high-severity vulnerability in HackerOne kindlegen node module, published on 1 Jun 2018. 

### Official description

Kindlegen is a simple Node.js wrapper of the official kindlegen program. Kindlegen versions before 1.1.0 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10575?

2 open source packages ship an affected version, including kindlegen. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kindlegen` | npm | All versions | 1.1.0 |
| `kindlegen` | npm | All versions | 1.1.0 |

Products: Hakatashi Kindlegen.

## How do I fix CVE-2016-10575?

Upgrade kindlegen to 1.1.0 or later.

## Is CVE-2016-10575 being exploited?

There is no known exploitation of CVE-2016-10575 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10575 and fix it if it is affected.

What it is: CVE-2016-10575 is a high-severity vulnerability in HackerOne kindlegen node module, published on 1 Jun 2018. 
Exploitation: There is no known exploitation of CVE-2016-10575 in the wild and no public exploit code.

Affected packages and fixed versions:
- kindlegen (npm): affected all versions; fixed in 1.1.0
- kindlegen (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10575/ (Markdown: https://insights.sbomify.com/CVE-2016-10575/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10575
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10575
- OSV: https://osv.dev/vulnerability/CVE-2016-10575

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10575/
Summaries are generated and may contain mistakes; the official description above is the record.
