# CVE-2016-10578: Downloads Resources over HTTP in unicode

> The unicode library downloads data over HTTP, allowing attackers to perform Man-in-the-Middle attacks to intercept or modify data.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-qjf4-7642-c57p

## What is CVE-2016-10578?

CVE-2016-10578 is a high-severity vulnerability in HackerOne unicode node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

unicode loads unicode data downloaded from unicode.org into nodejs. Unicode before 9.0.0 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10578?

2 open source packages ship an affected version, including unicode. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `unicode` | npm | All versions | 9.0.0 |
| `unicode` | npm | All versions | 9.0.0 |

Products: Unicode Project Unicode.

## How do I fix CVE-2016-10578?

Upgrade unicode to 9.0.0 or later.

## Is CVE-2016-10578 being exploited?

There is no known exploitation of CVE-2016-10578 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10578 and fix it if it is affected.

What it is: CVE-2016-10578 is a high-severity vulnerability in HackerOne unicode node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10578 in the wild and no public exploit code.

Affected packages and fixed versions:
- unicode (npm): affected all versions; fixed in 9.0.0
- unicode (npm): affected all versions; fixed in 9.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10578/ (Markdown: https://insights.sbomify.com/CVE-2016-10578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10578
- OSV: https://osv.dev/vulnerability/CVE-2016-10578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10578/
Summaries are generated and may contain mistakes; the official description above is the record.
