# CVE-2016-10579: chromedriver Downloads Resources over HTTP

> Attackers can execute arbitrary code by intercepting HTTP downloads of the Chromedriver binary, allowing binary replacement via MITM.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-jh5w-6964-x5cf

## What is CVE-2016-10579?

CVE-2016-10579 is a high-severity vulnerability in HackerOne chromedriver node module, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Chromedriver is an NPM wrapper for selenium ChromeDriver. Chromedriver before 2.26.1 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10579?

2 open source packages ship an affected version, including chromedriver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chromedriver` | npm | All versions | 2.25.2 |
| `chromedriver` | npm | All versions | 2.25.2 |

Products: Chromedriver Project Chromedriver.

## How do I fix CVE-2016-10579?

Upgrade chromedriver to 2.25.2 or later.

## Is CVE-2016-10579 being exploited?

There is no known exploitation of CVE-2016-10579 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne chromedriver node module

- [CVE-2023-26156](https://insights.sbomify.com/CVE-2023-26156/): chromedriver Command Injection vulnerability (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10579 and fix it if it is affected.

What it is: CVE-2016-10579 is a high-severity vulnerability in HackerOne chromedriver node module, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10579 in the wild and no public exploit code.

Affected packages and fixed versions:
- chromedriver (npm): affected all versions; fixed in 2.25.2
- chromedriver (npm): affected all versions; fixed in 2.25.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10579/ (Markdown: https://insights.sbomify.com/CVE-2016-10579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10579
- OSV: https://osv.dev/vulnerability/CVE-2016-10579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10579/
Summaries are generated and may contain mistakes; the official description above is the record.
