# CVE-2016-10602: Downloads Resources over HTTP in haxe

> Haxe downloads resources over HTTP, allowing attackers to perform MITM attacks and achieve remote code execution by replacing files.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-g785-775g-f2g8

## What is CVE-2016-10602?

CVE-2016-10602 is a high-severity vulnerability in HackerOne haxe node module, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

haxe is a cross-platform toolkit haxe downloads zipped resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested zip file with an attacker controlled zip file if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10602?

2 open source packages ship an affected version, including haxe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haxe` | npm | All versions | 5.0.10 |
| `haxe` | npm | All versions | 5.0.10 |

Products: Haxe Haxe.

## How do I fix CVE-2016-10602?

Upgrade haxe to 5.0.10 or later.

## Is CVE-2016-10602 being exploited?

There is no known exploitation of CVE-2016-10602 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne haxe node module

- [CVE-2016-10688](https://insights.sbomify.com/CVE-2016-10688/): Downloads Resources over HTTP in haxe3 (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10602 and fix it if it is affected.

What it is: CVE-2016-10602 is a high-severity vulnerability in HackerOne haxe node module, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10602 in the wild and no public exploit code.

Affected packages and fixed versions:
- haxe (npm): affected all versions; fixed in 5.0.10
- haxe (npm): affected all versions; fixed in 5.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10602/ (Markdown: https://insights.sbomify.com/CVE-2016-10602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10602
- OSV: https://osv.dev/vulnerability/CVE-2016-10602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10602/
Summaries are generated and may contain mistakes; the official description above is the record.
