{"answers":{"affected":"2 open source packages ship an affected version, including mystem3. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10626 in the wild and no public exploit code.","fix":"Upgrade mystem3 to 1.0.8 or later.","what":"CVE-2016-10626 is a high-severity vulnerability in HackerOne mystem3 node module, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10626 and fix it if it is affected.\n\nWhat it is: CVE-2016-10626 is a high-severity vulnerability in HackerOne mystem3 node module, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10626 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mystem3 (npm): affected all versions; fixed in 1.0.8\n- mystem3 (npm): affected all versions; fixed in 1.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10626/ (Markdown: https://insights.sbomify.com/CVE-2016-10626/index.md)","id":"CVE-2016-10626","markdown":"https://insights.sbomify.com/CVE-2016-10626/index.md","name":"CVE-2016-10626","record":{"aliases":["GHSA-747p-jfqv-f43r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js NLP library","requires_auth":"none","summary":"Attackers can execute arbitrary code by intercepting HTTP downloads of binary resources in the mystem3 Node.js module.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"mystem3","vendor":"mystem3_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-310","name":null},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"mystem3 is a NodeJS wrapper for the Yandex MyStem 3. mystem3 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Downloads Resources over HTTP in mystem3","id":"CVE-2016-10626","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Downloads Resources over HTTP in scala-bin","id":"CVE-2016-10627"},"packages":[{"ecosystem":"npm","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"mystem3","purl":null,"source":"GHSA-747p-jfqv-f43r"},{"ecosystem":"npm","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"mystem3","purl":"pkg:npm/mystem3","source":"GHSA-747p-jfqv-f43r"}],"prev":{"headline":"headless-browser-lite downloads Resources over HTTP","id":"CVE-2016-10625"},"products":["mystem3 node module"],"published":"2018-06-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary code by intercepting HTTP downloads of binary resources in the mystem3 Node.js module.","url":"https://insights.sbomify.com/CVE-2016-10626/"}