# CVE-2016-10638: Downloads Resources over HTTP in js-given

> An attacker can execute arbitrary code by intercepting HTTP downloads of binary resources in the js-given library.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rqwh-c535-j9hw

## What is CVE-2016-10638?

CVE-2016-10638 is a high-severity vulnerability in HackerOne js-given node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

js-given is a JavaScript frontend to jgiven. js-given downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.

Weakness: CWE-310, CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2016-10638?

2 open source packages ship an affected version, including js-given. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `js-given` | npm | All versions | 0.0.18 |
| `js-given` | npm | All versions | 0.0.18 |

Products: Js-Given Project Js-Given.

## How do I fix CVE-2016-10638?

Upgrade js-given to 0.0.18 or later.

## Is CVE-2016-10638 being exploited?

There is no known exploitation of CVE-2016-10638 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10638 and fix it if it is affected.

What it is: CVE-2016-10638 is a high-severity vulnerability in HackerOne js-given node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10638 in the wild and no public exploit code.

Affected packages and fixed versions:
- js-given (npm): affected all versions; fixed in 0.0.18
- js-given (npm): affected all versions; fixed in 0.0.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10638/ (Markdown: https://insights.sbomify.com/CVE-2016-10638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10638
- OSV: https://osv.dev/vulnerability/CVE-2016-10638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10638/
Summaries are generated and may contain mistakes; the official description above is the record.
