{"answers":{"affected":"2 open source packages ship an affected version, including alto-saxophone. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10694 in the wild and no public exploit code.","fix":"Upgrade alto-saxophone to 2.25.1 or later.","what":"CVE-2016-10694 is a high-severity vulnerability in HackerOne alto-saxophone node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10694 and fix it if it is affected.\n\nWhat it is: CVE-2016-10694 is a high-severity vulnerability in HackerOne alto-saxophone node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10694 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- alto-saxophone (npm): affected all versions; fixed in 2.25.1\n- alto-saxophone (npm): affected all versions; fixed in 2.25.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10694/ (Markdown: https://insights.sbomify.com/CVE-2016-10694/index.md)","id":"CVE-2016-10694","markdown":"https://insights.sbomify.com/CVE-2016-10694/index.md","name":"CVE-2016-10694","record":{"aliases":["GHSA-2p69-gxpm-5469"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js Chromedriver installer","requires_auth":"none","summary":"Attackers can execute arbitrary code by intercepting HTTP downloads of Chromedriver binaries during installation.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"alto-saxophone","vendor":"alto-saxophone_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-310","name":null},{"id":"CWE-311","name":"Missing Encryption of Sensitive Data"}],"description":"alto-saxophone is a module to install and launch Chromedriver for Mac, Linux or Windows. alto-saxophone versions below 2.25.1 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Downloads Resources over HTTP in alto-saxophone","id":"CVE-2016-10694","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"Downloads Resources over HTTP in npm-test-sqlite3-trunk","id":"CVE-2016-10695"},"packages":[{"ecosystem":"npm","fixed":["2.25.1"],"introduced":["0"],"last_affected":[],"package":"alto-saxophone","purl":null,"source":"GHSA-2p69-gxpm-5469"},{"ecosystem":"npm","fixed":["2.25.1"],"introduced":["0"],"last_affected":[],"package":"alto-saxophone","purl":"pkg:npm/alto-saxophone","source":"GHSA-2p69-gxpm-5469"}],"prev":{"headline":"Downloads Resources over HTTP in pm2-kafka","id":"CVE-2016-10693"},"products":["alto-saxophone node module"],"published":"2018-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary code by intercepting HTTP downloads of Chromedriver binaries during installation.","url":"https://insights.sbomify.com/CVE-2016-10694/"}