{"answers":{"affected":"2 open source packages ship an affected version, including ecstatic. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10703 in the wild and no public exploit code.","fix":"Upgrade ecstatic to 2.0.0 or later.","what":"CVE-2016-10703 is a high-severity denial of service vulnerability in n/a, published on 14 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10703 and fix it if it is affected.\n\nWhat it is: CVE-2016-10703 is a high-severity denial of service vulnerability in n/a, published on 14 Dec 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10703 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ecstatic (npm): affected all versions; fixed in 2.0.0\n- ecstatic (npm): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10703/ (Markdown: https://insights.sbomify.com/CVE-2016-10703/index.md)","id":"CVE-2016-10703","markdown":"https://insights.sbomify.com/CVE-2016-10703/index.md","name":"CVE-2016-10703","record":{"aliases":["GHSA-pm9p-9926-w68m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"npm ecstatic library","requires_auth":"none","summary":"Remote attackers can crash servers using the ecstatic npm library by sending malicious strings that trigger regular expression denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ecstatic","vendor":"ecstatic_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A regular expression Denial of Service (DoS) vulnerability in the file lib/ecstatic.js of the ecstatic npm package, before version 2.0.0, allows a remote attacker to overload and crash a server by passing a maliciously crafted string.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in ecstatic","id":"CVE-2016-10703","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-10704"},"packages":[{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":null,"source":"GHSA-pm9p-9926-w68m"},{"ecosystem":"npm","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"ecstatic","purl":"pkg:npm/ecstatic","source":"GHSA-pm9p-9926-w68m"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2016-10702"},"products":["n/a"],"published":"2017-12-14","related":[{"cvss_score":7.5,"headline":"Denial of Service in ecstatic","id":"CVE-2019-10775","kev_date_added":null,"published":"2020-01-02"},{"cvss_score":7.5,"headline":"Denial of Service in ecstatic","id":"CVE-2015-9242","kev_date_added":null,"published":"2018-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can crash servers using the ecstatic npm library by sending malicious strings that trigger regular expression denial of service.","url":"https://insights.sbomify.com/CVE-2016-10703/"}