CVE-2016-10707 Denial of Service in jquery

High 7.5 Published Updated

An attacker can cause a denial of service in applications using jQuery by triggering infinite recursion via mixed-case boolean attribute names.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2016-10707?

CVE-2016-10707 is a high-severity denial of service vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.

Weakness: CWE-674

Which versions are affected by CVE-2016-10707?

8 open source packages ship an affected version, including org.webjars.npm:jquery, jQuery and jquery-rails. It affects 1 product.

PackageAffectedFixed in
org.webjars.npm:jquery MavenFrom 3.0.0-rc13.0.0
org.webjars.npm:jquery MavenFrom 3.0.0-rc13.0.0
jQuery NuGetFrom 3.0.0-rc.13.0.0
jQuery NuGetFrom 3.0.0-rc.13.0.0
jquery-rails RubyGemsFrom 3.0.0-rc.13.0.0
jquery-rails RubyGemsFrom 3.0.0-rc.13.0.0
2 more packages
jquery npmFrom 3.0.0-rc.13.0.0
jquery npmFrom 3.0.0-rc.13.0.0

Products include Jquery Jquery.

How do I fix CVE-2016-10707?

Upgrade org.webjars.npm:jquery to 3.0.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2016-10707 being exploited?

There is no known exploitation of CVE-2016-10707 in the wild and no public exploit code.

Sources

Also known as GHSA-mhpp-875w-9cpv.

Is CVE-2016-10707 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free