{"answers":{"affected":"8 open source packages ship an affected version, including org.webjars.npm:jquery, jQuery and jquery-rails. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10707 in the wild and no public exploit code.","fix":"Upgrade org.webjars.npm:jquery to 3.0.0 or later.","what":"CVE-2016-10707 is a high-severity denial of service vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10707 and fix it if it is affected.\n\nWhat it is: CVE-2016-10707 is a high-severity denial of service vulnerability in n/a, published on 18 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10707 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.webjars.npm:jquery (Maven): affected from 3.0.0-rc1; fixed in 3.0.0\n- org.webjars.npm:jquery (Maven): affected from 3.0.0-rc1; fixed in 3.0.0\n- jQuery (NuGet): affected from 3.0.0-rc.1; fixed in 3.0.0\n- jQuery (NuGet): affected from 3.0.0-rc.1; fixed in 3.0.0\n- jquery-rails (RubyGems): affected from 3.0.0-rc.1; fixed in 3.0.0\n- jquery-rails (RubyGems): affected from 3.0.0-rc.1; fixed in 3.0.0\n- jquery (npm): affected from 3.0.0-rc.1; fixed in 3.0.0\n- jquery (npm): affected from 3.0.0-rc.1; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10707/ (Markdown: https://insights.sbomify.com/CVE-2016-10707/index.md)","id":"CVE-2016-10707","markdown":"https://insights.sbomify.com/CVE-2016-10707/index.md","name":"CVE-2016-10707","record":{"aliases":["GHSA-mhpp-875w-9cpv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using jQuery by triggering infinite recursion via mixed-case boolean attribute names.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jquery","vendor":"jquery"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names. Any attribute getter using a mixed-cased name for boolean attributes goes into an infinite recursion, exceeding the stack call limit.","ecosystems":["Maven","NuGet","RubyGems","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in jquery","id":"CVE-2016-10707","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2016"},"n_packages":8,"n_references":3,"next":{"headline":"Null dereference in n/a","id":"CVE-2016-10708"},"packages":[{"ecosystem":"Maven","fixed":["3.0.0"],"introduced":["3.0.0-rc1"],"last_affected":[],"package":"org.webjars.npm:jquery","purl":null,"source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"Maven","fixed":["3.0.0"],"introduced":["3.0.0-rc1"],"last_affected":[],"package":"org.webjars.npm:jquery","purl":"pkg:maven/org.webjars.npm/jquery","source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"NuGet","fixed":["3.0.0"],"introduced":["3.0.0-rc.1"],"last_affected":[],"package":"jQuery","purl":null,"source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"NuGet","fixed":["3.0.0"],"introduced":["3.0.0-rc.1"],"last_affected":[],"package":"jQuery","purl":"pkg:nuget/jQuery","source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"RubyGems","fixed":["3.0.0"],"introduced":["3.0.0-rc.1"],"last_affected":[],"package":"jquery-rails","purl":null,"source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"RubyGems","fixed":["3.0.0"],"introduced":["3.0.0-rc.1"],"last_affected":[],"package":"jquery-rails","purl":"pkg:gem/jquery-rails","source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["3.0.0-rc.1"],"last_affected":[],"package":"jquery","purl":null,"source":"GHSA-mhpp-875w-9cpv"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["3.0.0-rc.1"],"last_affected":[],"package":"jquery","purl":"pkg:npm/jquery","source":"GHSA-mhpp-875w-9cpv"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-10706"},"products":["n/a"],"published":"2018-01-18","related":[{"cvss_score":6.1,"headline":"Cross-Site Scripting in jquery","id":"CVE-2020-7656","kev_date_added":null,"published":"2020-05-19"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2018-18405","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":6.1,"headline":"Cross-Site Scripting in jquery","id":"CVE-2012-6708","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-Site Scripting (XSS) in jquery","id":"CVE-2015-9251","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2014-6071","kev_date_added":null,"published":"2018-01-16"},{"cvss_score":5,"headline":"Information disclosure in n/a","id":"CVE-2007-2379","kev_date_added":null,"published":"2007-04-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using jQuery by triggering infinite recursion via mixed-case boolean attribute names.","url":"https://insights.sbomify.com/CVE-2016-10707/"}