# CVE-2016-10717: Security feature bypass in n/a

> Attackers can bypass Malwarebytes protections by manipulating exclusion files, allowing execution of malware and access to blocked websites.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Mar 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mxwp-9ccw-xhq3

## What is CVE-2016-10717?

CVE-2016-10717 is a high-severity vulnerability in n/a, published on 21 Mar 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in the encryption and permission implementation of Malwarebytes Anti-Malware consumer version 2.2.1 and prior (fixed in 3.0.4) allows an attacker to take control of the whitelisting feature (exclusions.dat under %SYSTEMDRIVE%\ProgramData) to permit execution of unauthorized applications including malware and malicious websites. Files blacklisted by Malwarebytes Malware Protect can be executed, and domains blacklisted by Malwarebytes Web Protect can be reached through HTTP.

Weakness: CWE-254

## Which versions are affected by CVE-2016-10717?

It affects 1 product.


Products: Malwarebytes Malwarebytes Anti-Malware.

## How do I fix CVE-2016-10717?

No fix has been published for CVE-2016-10717 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-10717 being exploited?

There is no known exploitation of CVE-2016-10717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10717 and fix it if it is affected.

What it is: CVE-2016-10717 is a high-severity vulnerability in n/a, published on 21 Mar 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10717 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10717/ (Markdown: https://insights.sbomify.com/CVE-2016-10717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10717
- OSV: https://osv.dev/vulnerability/CVE-2016-10717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10717/
Summaries are generated and may contain mistakes; the official description above is the record.
