# CVE-2016-10726: High severity vulnerability that affects org.dspace:dspace-xmlui

> Attackers can read arbitrary files on the server via directory traversal in the XMLUI themes path, affecting DSpace installations.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-4m9r-5gqp-7j82

## What is CVE-2016-10726?

CVE-2016-10726 is a high-severity path traversal vulnerability in n/a, published on 10 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The XMLUI feature in DSpace before 3.6, 4.x before 4.5, and 5.x before 5.5 allows directory traversal via the themes/ path in an attack with two or more arbitrary characters and a colon before a pathname, as demonstrated by a themes/Reference/aa:etc/passwd URI.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-10726?

6 open source packages ship an affected version, including org.dspace:dspace-xmlui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dspace:dspace-xmlui` | Maven | All versions | 3.6 |
| `org.dspace:dspace-xmlui` | Maven | All versions | 3.6 |
| `org.dspace:dspace-xmlui` | Maven | From 4.0 | 4.5 |
| `org.dspace:dspace-xmlui` | Maven | From 4.0 | 4.5 |
| `org.dspace:dspace-xmlui` | Maven | From 5.0 | 5.5 |
| `org.dspace:dspace-xmlui` | Maven | From 5.0 | 5.5 |

Products: Duraspace Dspace.

## How do I fix CVE-2016-10726?

Upgrade org.dspace:dspace-xmlui to a fixed version for your release line: 3.6, 4.5 or 5.5.

## Is CVE-2016-10726 being exploited?

There is no known exploitation of CVE-2016-10726 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/DSpace__DSpace_CVE-2016-10726_4-4 (github_poc): https://github.com/shoucheng3/DSpace__DSpace_CVE-2016-10726_4-4

## Other vulnerabilities in n/a

- [CVE-2022-31194](https://insights.sbomify.com/CVE-2022-31194/): Path traversal vulnerabilities in DSpace JSPUI submission upload (high 8.2)
- [CVE-2022-31195](https://insights.sbomify.com/CVE-2022-31195/): Path traversal vulnerability in Simple Archive Format package import in DSpace (high 7.2)
- [CVE-2021-41189](https://insights.sbomify.com/CVE-2021-41189/): Communities and collections administrators can escalate their privilege up to system administrator (high 7.2)
- [CVE-2022-31191](https://insights.sbomify.com/CVE-2022-31191/): Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools (high 7.1)
- [CVE-2022-31192](https://insights.sbomify.com/CVE-2022-31192/): Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10726 and fix it if it is affected.

What it is: CVE-2016-10726 is a high-severity path traversal vulnerability in n/a, published on 10 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10726 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dspace:dspace-xmlui (Maven): affected all versions; fixed in 3.6
- org.dspace:dspace-xmlui (Maven): affected all versions; fixed in 3.6
- org.dspace:dspace-xmlui (Maven): affected from 4.0; fixed in 4.5
- org.dspace:dspace-xmlui (Maven): affected from 4.0; fixed in 4.5
- org.dspace:dspace-xmlui (Maven): affected from 5.0; fixed in 5.5
- org.dspace:dspace-xmlui (Maven): affected from 5.0; fixed in 5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10726/ (Markdown: https://insights.sbomify.com/CVE-2016-10726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10726
- OSV: https://osv.dev/vulnerability/CVE-2016-10726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10726/
Summaries are generated and may contain mistakes; the official description above is the record.
