CVE-2016-10735 Bootstrap Cross-site Scripting vulnerability
Cross-site scripting vulnerability in Bootstrap allows attackers to execute arbitrary scripts via the data-target attribute.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-10735?
CVE-2016-10735 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041.
Weakness: CWE-79
Which versions are affected by CVE-2016-10735?
24 open source packages ship an affected version, including bootstrap, org.webjars:bootstrap and bootstrap.sass. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
bootstrap NuGet | From 2.0.4 | 3.4.0 |
bootstrap NuGet | From 2.0.4 | 3.4.0 |
bootstrap NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
bootstrap NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
bootstrap RubyGems | All versions | 4.0.0-beta.2 |
bootstrap RubyGems | All versions | 4.0.0-beta.2 |
18 more packages
bootstrap npm | From 2.0.4 | 3.4.0 |
bootstrap npm | From 2.0.4 | 3.4.0 |
bootstrap npm | From 4.0.0-beta | 4.0.0-beta.2 |
bootstrap npm | From 4.0.0-beta | 4.0.0-beta.2 |
org.webjars:bootstrap Maven | From 2.0.4 | 3.4.0 |
org.webjars:bootstrap Maven | From 2.0.4 | 3.4.0 |
org.webjars:bootstrap Maven | From 4.0.0-beta | 4.0.0-beta.2 |
org.webjars:bootstrap Maven | From 4.0.0-beta | 4.0.0-beta.2 |
bootstrap.sass NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
bootstrap.sass NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
twbs/bootstrap Packagist | From 2.0.4 | 3.4.0 |
twbs/bootstrap Packagist | From 2.0.4 | 3.4.0 |
twbs/bootstrap Packagist | From 4.0.0-beta | 4.0.0-beta.2 |
twbs/bootstrap Packagist | From 4.0.0-beta | 4.0.0-beta.2 |
bootstrap-sass RubyGems | From 2.0.4 | 3.4.0 |
bootstrap-sass RubyGems | From 2.0.4 | 3.4.0 |
bootstrap-sass npm | From 2.0.4 | 3.4.0 |
bootstrap-sass npm | From 2.0.4 | 3.4.0 |
Products include Getbootstrap Bootstrap.
How do I fix CVE-2016-10735?
Upgrade bootstrap to a fixed version for your release line: 3.4.0 or 4.0.0-beta.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-10735 being exploited?
There is no known exploitation of CVE-2016-10735 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2016-10735, GHSA-4p24-vmcr-4gqj, UBUNTU-CVE-2016-10735.