# CVE-2016-10735: Bootstrap Cross-site Scripting vulnerability

> Cross-site scripting vulnerability in Bootstrap allows attackers to execute arbitrary scripts via the data-target attribute.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Jan 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-10735, GHSA-4p24-vmcr-4gqj, UBUNTU-CVE-2016-10735

## What is CVE-2016-10735?

CVE-2016-10735 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-10735?

24 open source packages ship an affected version, including bootstrap, org.webjars:bootstrap and bootstrap.sass. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bootstrap` | NuGet | From 2.0.4 | 3.4.0 |
| `bootstrap` | NuGet | From 2.0.4 | 3.4.0 |
| `bootstrap` | NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
| `bootstrap` | NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
| `bootstrap` | RubyGems | All versions | 4.0.0-beta.2 |
| `bootstrap` | RubyGems | All versions | 4.0.0-beta.2 |
| `bootstrap` | npm | From 2.0.4 | 3.4.0 |
| `bootstrap` | npm | From 2.0.4 | 3.4.0 |
| `bootstrap` | npm | From 4.0.0-beta | 4.0.0-beta.2 |
| `bootstrap` | npm | From 4.0.0-beta | 4.0.0-beta.2 |
| `org.webjars:bootstrap` | Maven | From 2.0.4 | 3.4.0 |
| `org.webjars:bootstrap` | Maven | From 2.0.4 | 3.4.0 |
| `org.webjars:bootstrap` | Maven | From 4.0.0-beta | 4.0.0-beta.2 |
| `org.webjars:bootstrap` | Maven | From 4.0.0-beta | 4.0.0-beta.2 |
| `bootstrap.sass` | NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
| `bootstrap.sass` | NuGet | From 4.0.0-beta | 4.0.0-beta.2 |
| `twbs/bootstrap` | Packagist | From 2.0.4 | 3.4.0 |
| `twbs/bootstrap` | Packagist | From 2.0.4 | 3.4.0 |
| `twbs/bootstrap` | Packagist | From 4.0.0-beta | 4.0.0-beta.2 |
| `twbs/bootstrap` | Packagist | From 4.0.0-beta | 4.0.0-beta.2 |
| `bootstrap-sass` | RubyGems | From 2.0.4 | 3.4.0 |
| `bootstrap-sass` | RubyGems | From 2.0.4 | 3.4.0 |
| `bootstrap-sass` | npm | From 2.0.4 | 3.4.0 |
| `bootstrap-sass` | npm | From 2.0.4 | 3.4.0 |

Products: Getbootstrap Bootstrap.

## How do I fix CVE-2016-10735?

Upgrade bootstrap to a fixed version for your release line: 3.4.0 or 4.0.0-beta.2.

## Is CVE-2016-10735 being exploited?

There is no known exploitation of CVE-2016-10735 in the wild and no public exploit code.

Public exploit code:

- A poc for Bootstrap XSS(CVE-2024-6485、CVE-2016-10735、CVE-2019-8331、CVE-2018-14040) (github_poc): https://github.com/Yumeae/Bootstrap-with-XSS

## Other vulnerabilities in n/a

- [CVE-2018-20676](https://insights.sbomify.com/CVE-2018-20676/): XSS vulnerability that affects bootstrap (medium 6.1)
- [CVE-2018-20677](https://insights.sbomify.com/CVE-2018-20677/): bootstrap Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2018-14041](https://insights.sbomify.com/CVE-2018-14041/): Bootstrap Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2018-14042](https://insights.sbomify.com/CVE-2018-14042/): Bootstrap Cross-site Scripting vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10735 and fix it if it is affected.

What it is: CVE-2016-10735 is a medium-severity cross-site scripting vulnerability in n/a, published on 9 Jan 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10735 in the wild and no public exploit code.

Affected packages and fixed versions:
- bootstrap (NuGet): affected from 2.0.4; fixed in 3.4.0
- bootstrap (NuGet): affected from 2.0.4; fixed in 3.4.0
- bootstrap (NuGet): affected from 4.0.0-beta; fixed in 4.0.0-beta.2
- bootstrap (NuGet): affected from 4.0.0-beta; fixed in 4.0.0-beta.2
- bootstrap (RubyGems): affected all versions; fixed in 4.0.0-beta.2
- bootstrap (RubyGems): affected all versions; fixed in 4.0.0-beta.2
- bootstrap (npm): affected from 2.0.4; fixed in 3.4.0
- bootstrap (npm): affected from 2.0.4; fixed in 3.4.0
- bootstrap (npm): affected from 4.0.0-beta; fixed in 4.0.0-beta.2
- bootstrap (npm): affected from 4.0.0-beta; fixed in 4.0.0-beta.2
- org.webjars:bootstrap (Maven): affected from 2.0.4; fixed in 3.4.0
- org.webjars:bootstrap (Maven): affected from 2.0.4; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10735/ (Markdown: https://insights.sbomify.com/CVE-2016-10735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10735
- OSV: https://osv.dev/vulnerability/CVE-2016-10735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10735/
Summaries are generated and may contain mistakes; the official description above is the record.
