{"answers":{"affected":"2 open source packages ship an affected version, including select2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10744 in the wild and no public exploit code.","fix":"Upgrade select2 to 4.0.6 or later.","what":"CVE-2016-10744 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-10744 and fix it if it is affected.\n\nWhat it is: CVE-2016-10744 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-10744 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- select2 (npm): affected all versions; fixed in 4.0.6\n- select2 (npm): affected all versions; fixed in 4.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10744/ (Markdown: https://insights.sbomify.com/CVE-2016-10744/index.md)","id":"CVE-2016-10744","markdown":"https://insights.sbomify.com/CVE-2016-10744/index.md","name":"CVE-2016-10744","record":{"aliases":["GHSA-rf66-hmqf-q3fc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript select library","requires_auth":"none","summary":"Cross-site scripting vulnerability in Select2 library allows attackers to execute arbitrary scripts via Ajax remote data loading with HTML templates.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"select2","vendor":"select2"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Select2 through 4.0.5, as used in Snipe-IT and other products, rich selectlists allow XSS. This affects use cases with Ajax remote data loading when HTML templates are used to display listbox data.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in Select2","id":"CVE-2016-10744","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2016"},"n_packages":2,"n_references":3,"next":{"headline":"Jinja2 sandbox escape vulnerability","id":"CVE-2016-10745"},"packages":[{"ecosystem":"npm","fixed":["4.0.6"],"introduced":["0"],"last_affected":[],"package":"select2","purl":null,"source":"GHSA-rf66-hmqf-q3fc"},{"ecosystem":"npm","fixed":["4.0.6"],"introduced":["0"],"last_affected":[],"package":"select2","purl":"pkg:npm/select2","source":"GHSA-rf66-hmqf-q3fc"}],"prev":{"headline":"Weak cryptography in n/a","id":"CVE-2016-10743"},"products":["n/a"],"published":"2019-03-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Select2 library allows attackers to execute arbitrary scripts via Ajax remote data loading with HTML templates.","url":"https://insights.sbomify.com/CVE-2016-10744/"}