# CVE-2016-10744: Improper Neutralization of Input During Web Page Generation in Select2

> Cross-site scripting vulnerability in Select2 library allows attackers to execute arbitrary scripts via Ajax remote data loading with HTML templates.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-rf66-hmqf-q3fc

## What is CVE-2016-10744?

CVE-2016-10744 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Select2 through 4.0.5, as used in Snipe-IT and other products, rich selectlists allow XSS. This affects use cases with Ajax remote data loading when HTML templates are used to display listbox data.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-10744?

2 open source packages ship an affected version, including select2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `select2` | npm | All versions | 4.0.6 |
| `select2` | npm | All versions | 4.0.6 |

Products: Select2 Select2.

## How do I fix CVE-2016-10744?

Upgrade select2 to 4.0.6 or later.

## Is CVE-2016-10744 being exploited?

There is no known exploitation of CVE-2016-10744 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10744 and fix it if it is affected.

What it is: CVE-2016-10744 is a medium-severity cross-site scripting vulnerability in n/a, published on 27 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-10744 in the wild and no public exploit code.

Affected packages and fixed versions:
- select2 (npm): affected all versions; fixed in 4.0.6
- select2 (npm): affected all versions; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10744/ (Markdown: https://insights.sbomify.com/CVE-2016-10744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10744
- OSV: https://osv.dev/vulnerability/CVE-2016-10744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10744/
Summaries are generated and may contain mistakes; the official description above is the record.
