{"answers":{"affected":"3 open source packages ship an affected version, including openssl. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-10931 in the wild and no public exploit code.","fix":"Upgrade openssl to 0.9.0 or later.","what":"CVE-2016-10931 is a high-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-10931 and fix it if it is affected.\n\nWhat it is: CVE-2016-10931 is a high-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-10931 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl (crates.io): affected all versions; fixed in 0.9.0\n- openssl (crates.io): affected all versions; fixed in 0.9.0\n- openssl (crates.io): affected from 0.0.0-0; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-10931/ (Markdown: https://insights.sbomify.com/CVE-2016-10931/index.md)","id":"CVE-2016-10931","markdown":"https://insights.sbomify.com/CVE-2016-10931/index.md","name":"CVE-2016-10931","record":{"aliases":["GHSA-34p9-f4q3-c4r7","RUSTSEC-2016-0001"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust OpenSSL crate","requires_auth":"none","summary":"Attackers can perform man-in-the-middle attacks because the Rust OpenSSL crate disables certificate verification by default and lacks hostname verification APIs.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rust-openssl","vendor":"rust-openssl_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"An issue was discovered in the openssl crate before 0.9.0 for Rust. There is an SSL/TLS man-in-the-middle vulnerability because certificate verification is off by default and there is no API for hostname verification.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in openssl","id":"CVE-2016-10931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"security_feature_bypass","year":"2016"},"n_packages":3,"n_references":1,"next":{"headline":"HTTPS MitM vulnerability due to lack of hostname verification","id":"CVE-2016-10932"},"packages":[{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":null,"source":"GHSA-34p9-f4q3-c4r7"},{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"GHSA-34p9-f4q3-c4r7"},{"ecosystem":"crates.io","fixed":["0.9.0"],"introduced":["0.0.0-0"],"last_affected":[],"package":"openssl","purl":"pkg:cargo/openssl","source":"RUSTSEC-2016-0001"}],"prev":{"headline":"Missing authorization in n/a","id":"CVE-2016-10930"},"products":["n/a"],"published":"2019-08-26","related":[{"cvss_score":9.8,"headline":"Use after free in openssl","id":"CVE-2018-20997","kev_date_added":null,"published":"2019-08-26"},{"cvss_score":8.3,"headline":"rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer","id":"CVE-2026-41898","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":8.1,"headline":"rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check","id":"CVE-2026-41681","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.2,"headline":"rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1","id":"CVE-2026-41676","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.2,"headline":"rust-openssl: Incorrect bounds assertion in aes key wrap","id":"CVE-2026-41678","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":1.7,"headline":"rust-openssl: Out-of-bounds read in PEM password callback when user callback returns an oversized length","id":"CVE-2026-41677","kev_date_added":null,"published":"2026-04-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can perform man-in-the-middle attacks because the Rust OpenSSL crate disables certificate verification by default and lacks hostname verification APIs.","url":"https://insights.sbomify.com/CVE-2016-10931/"}