# CVE-2016-10931: Improper Certificate Validation in openssl

> Attackers can perform man-in-the-middle attacks because the Rust OpenSSL crate disables certificate verification by default and lacks hostname verification APIs.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Aug 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-34p9-f4q3-c4r7, RUSTSEC-2016-0001

## What is CVE-2016-10931?

CVE-2016-10931 is a high-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the openssl crate before 0.9.0 for Rust. There is an SSL/TLS man-in-the-middle vulnerability because certificate verification is off by default and there is no API for hostname verification.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-10931?

3 open source packages ship an affected version, including openssl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | crates.io | All versions | 0.9.0 |
| `openssl` | crates.io | All versions | 0.9.0 |
| `openssl` | crates.io | From 0.0.0-0 | 0.9.0 |

Products: Rust-Openssl Project Rust-Openssl.

## How do I fix CVE-2016-10931?

Upgrade openssl to 0.9.0 or later.

## Is CVE-2016-10931 being exploited?

There is no known exploitation of CVE-2016-10931 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-20997](https://insights.sbomify.com/CVE-2018-20997/): Use after free in openssl (critical 9.8)
- [CVE-2026-41898](https://insights.sbomify.com/CVE-2026-41898/): rust-openssl: Unchecked callback length in PSK/cookie trampolines leaks adjacent memory to peer (high 8.3)
- [CVE-2026-41681](https://insights.sbomify.com/CVE-2026-41681/): rust-openssl: MdCtxRef::digest_final() writes past caller buffer with no length check (high 8.1)
- [CVE-2026-41676](https://insights.sbomify.com/CVE-2026-41676/): rust-openssl: Deriver::derive and PkeyCtxRef::derive can overflow short buffers on OpenSSL 1.1.1 (high 7.2)
- [CVE-2026-41678](https://insights.sbomify.com/CVE-2026-41678/): rust-openssl: Incorrect bounds assertion in aes key wrap (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10931 and fix it if it is affected.

What it is: CVE-2016-10931 is a high-severity vulnerability in n/a, published on 26 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10931 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (crates.io): affected all versions; fixed in 0.9.0
- openssl (crates.io): affected all versions; fixed in 0.9.0
- openssl (crates.io): affected from 0.0.0-0; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10931/ (Markdown: https://insights.sbomify.com/CVE-2016-10931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10931
- OSV: https://osv.dev/vulnerability/CVE-2016-10931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10931/
Summaries are generated and may contain mistakes; the official description above is the record.
