# CVE-2016-10959: File upload in n/a

> Authenticated attackers can upload arbitrary files via CSRF, potentially leading to remote code execution on WordPress sites using the estatik plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Sep 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-x4w6-xc3h-38vf

## What is CVE-2016-10959?

CVE-2016-10959 is a medium-severity vulnerability in n/a, published on 16 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The estatik plugin before 2.3.1 for WordPress has authenticated arbitrary file upload (exploitable with CSRF) via es_media_images[] to wp-admin/admin-ajax.php.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2016-10959?

It affects 1 product.


Products: Estatik Estatik.

## How do I fix CVE-2016-10959?

No fix has been published for CVE-2016-10959 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-10959 being exploited?

There is no known exploitation of CVE-2016-10959 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-6049](https://insights.sbomify.com/CVE-2023-6049/): Estatik Real Estate Plugin < 4.1.1 - Unauthenticated PHP Object Injection (critical 9.8)
- [CVE-2016-10958](https://insights.sbomify.com/CVE-2016-10958/): File upload in n/a (high 7.5)
- [CVE-2023-6048](https://insights.sbomify.com/CVE-2023-6048/): Estatik Real Estate Plugin < 4.1.1 - Subscriber+ Arbitrary Option Update (medium 6.5)
- [CVE-2023-6050](https://insights.sbomify.com/CVE-2023-6050/): Estatik Real Estate Plugin < 4.1.1 - Reflected XSS (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-10959 and fix it if it is affected.

What it is: CVE-2016-10959 is a medium-severity vulnerability in n/a, published on 16 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-10959 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-10959/ (Markdown: https://insights.sbomify.com/CVE-2016-10959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-10959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-10959
- OSV: https://osv.dev/vulnerability/CVE-2016-10959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-10959/
Summaries are generated and may contain mistakes; the official description above is the record.
