# CVE-2016-11011: Privilege escalation in n/a

> A privilege escalation vulnerability in the wp-invoice WordPress plugin allows attackers to gain elevated permissions via the wpi_update_user_option function.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Sep 2019
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-5fmq-768p-g46x

## What is CVE-2016-11011?

CVE-2016-11011 is a medium-severity vulnerability in n/a, published on 20 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The wp-invoice plugin before 4.1.1 for WordPress has wpi_update_user_option privilege escalation.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2016-11011?

It affects 1 product.


Products: Usabilitydynamics Wp-Invoice.

## How do I fix CVE-2016-11011?

No fix has been published for CVE-2016-11011 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-11011 being exploited?

There is no known exploitation of CVE-2016-11011 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-1617](https://insights.sbomify.com/CVE-2022-1617/): WP-Invoice <= 4.3.1 - Stored Cross-Site Scripting via CSRF (medium 6.1)
- [CVE-2016-11006](https://insights.sbomify.com/CVE-2016-11006/): Missing authorization in n/a (medium 5.3)
- [CVE-2016-11007](https://insights.sbomify.com/CVE-2016-11007/): Missing authorization in n/a (medium 5.3)
- [CVE-2016-11008](https://insights.sbomify.com/CVE-2016-11008/): The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over wpi_paypal payer metadata updates. (medium 5.3)
- [CVE-2016-11009](https://insights.sbomify.com/CVE-2016-11009/): The wp-invoice plugin before 4.1.1 for WordPress has incorrect access control over wpi_interkassa payer metadata updates. (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-11011 and fix it if it is affected.

What it is: CVE-2016-11011 is a medium-severity vulnerability in n/a, published on 20 Sep 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-11011 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-11011/ (Markdown: https://insights.sbomify.com/CVE-2016-11011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-11011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-11011
- OSV: https://osv.dev/vulnerability/CVE-2016-11011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-11011/
Summaries are generated and may contain mistakes; the official description above is the record.
