# CVE-2016-11069: Mattermost Server does not enforce rate limits on password change attempts

> Attackers can bypass brute-force protections during password changes, potentially leading to account takeover in Mattermost Server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-qrf6-h5fc-7m96, GO-2025-4051

## What is CVE-2016-11069?

CVE-2016-11069 is a high-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Mattermost Server before 3.2.0. It mishandles brute-force attempts at password change.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2016-11069?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | All versions | 3.2.0 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 3.2.0 |
| `github.com/mattermost/mattermost-server` | Go | All versions | 3.2.0+incompatible |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2016-11069?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.2.0 or 3.2.0+incompatible.

## Is CVE-2016-11069 being exploited?

There is no known exploitation of CVE-2016-11069 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-11069 and fix it if it is affected.

What it is: CVE-2016-11069 is a high-severity vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-11069 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.2.0
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.2.0
- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.2.0+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-11069/ (Markdown: https://insights.sbomify.com/CVE-2016-11069/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-11069
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-11069
- OSV: https://osv.dev/vulnerability/CVE-2016-11069

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-11069/
Summaries are generated and may contain mistakes; the official description above is the record.
