{"answers":{"affected":"3 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-11071 in the wild and no public exploit code.","fix":"Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 3.1.0 or 3.1.0+incompatible.","what":"CVE-2016-11071 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-11071 and fix it if it is affected.\n\nWhat it is: CVE-2016-11071 is a medium-severity cross-site scripting vulnerability in Mattermost Mattermost Server, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-11071 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.1.0\n- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.1.0\n- github.com/mattermost/mattermost-server (Go): affected all versions; fixed in 3.1.0+incompatible\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-11071/ (Markdown: https://insights.sbomify.com/CVE-2016-11071/index.md)","id":"CVE-2016-11071","markdown":"https://insights.sbomify.com/CVE-2016-11071/index.md","name":"CVE-2016-11071","record":{"aliases":["GHSA-h3qg-w9j5-wh3m","GO-2025-4058"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Mattermost Server","requires_auth":"none","summary":"Cross-site scripting vulnerability in Mattermost Server allows attackers to inject scripts due to missing noreferrer and noopener protections.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mattermost_server","vendor":"mattermost"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in Mattermost Server before 3.1.0. It allows XSS because the noreferrer and noopener protection mechanisms were not in place.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mattermost Server is vulnerable to XSS through lack of link relationship attributes `noreferrer` and `noopener`","id":"CVE-2016-11071","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"mattermost:mattermost_server","products":["mattermost:mattermost_server"],"type":"xss","year":"2016"},"n_packages":3,"n_references":1,"next":{"headline":"Mattermost Server's Session ID and Session Token are potentially compromised","id":"CVE-2016-11072"},"packages":[{"ecosystem":"Go","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":null,"source":"GHSA-h3qg-w9j5-wh3m"},{"ecosystem":"Go","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","source":"GHSA-h3qg-w9j5-wh3m"},{"ecosystem":"Go","fixed":["3.1.0+incompatible"],"introduced":["0"],"last_affected":[],"package":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","source":"GO-2025-4058"}],"prev":{"headline":"Mattermost Server is vulnerable to XSS through customizable theme color-code values","id":"CVE-2016-11070"},"products":["n/a"],"published":"2020-06-19","related":[{"cvss_score":9.9,"headline":"Account takeover on OAuth/OpenID-enabled servers","id":"CVE-2025-12419","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Account Takeover via Code Exchange Endpoint","id":"CVE-2025-12421","kev_date_added":null,"published":"2025-11-27"},{"cvss_score":9.9,"headline":"Path Traversal Leading to RCE by Any Authenticated Mattermost User","id":"CVE-2025-4981","kev_date_added":null,"published":"2025-06-20"},{"cvss_score":9.9,"headline":"Arbitrary file read via block duplication in Mattermost Boards","id":"CVE-2025-20051","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.9,"headline":"Arbitrary file read in Mattermost Boards via import \u0026 export board archive","id":"CVE-2025-25279","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":9.8,"headline":"Mattermost Server: Insufficient Password-Reset Link Invalidation","id":"CVE-2016-11074","kev_date_added":null,"published":"2020-06-19"},{"cvss_score":9.8,"headline":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","id":"CVE-2017-18885","kev_date_added":null,"published":"2020-06-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in Mattermost Server allows attackers to inject scripts due to missing noreferrer and noopener protections.","url":"https://insights.sbomify.com/CVE-2016-11071/"}