{"answers":{"affected":"2 open source packages ship an affected version, including oauth. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-11086 in the wild and no public exploit code.","fix":"Upgrade oauth to 0.5.5 or later.","what":"CVE-2016-11086 is a high-severity vulnerability in n/a, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-11086 and fix it if it is affected.\n\nWhat it is: CVE-2016-11086 is a high-severity vulnerability in n/a, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-11086 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- oauth (RubyGems): affected all versions; fixed in 0.5.5\n- oauth (RubyGems): affected all versions; fixed in 0.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-11086/ (Markdown: https://insights.sbomify.com/CVE-2016-11086/index.md)","id":"CVE-2016-11086","markdown":"https://insights.sbomify.com/CVE-2016-11086/index.md","name":"CVE-2016-11086","record":{"aliases":["DEBIAN-CVE-2016-11086","GHSA-7359-3c6r-hfc2","UBUNTU-CVE-2016-11086"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OAuth library","requires_auth":"none","summary":"Man-in-the-middle attackers can spoof servers and obtain sensitive information due to missing X.509 certificate verification in the oauth-ruby gem.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"oauth-ruby","vendor":"oauth-ruby_project"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Certificate Validation in oauth ruby gem","id":"CVE-2016-11086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"weak_cryptography","year":"2016"},"n_packages":2,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-15001"},"packages":[{"ecosystem":"RubyGems","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"oauth","purl":null,"source":"GHSA-7359-3c6r-hfc2"},{"ecosystem":"RubyGems","fixed":["0.5.5"],"introduced":["0"],"last_affected":[],"package":"oauth","purl":"pkg:gem/oauth","source":"GHSA-7359-3c6r-hfc2"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2016-11085"},"products":["n/a"],"published":"2020-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Man-in-the-middle attackers can spoof servers and obtain sensitive information due to missing X.509 certificate verification in the oauth-ruby gem.","url":"https://insights.sbomify.com/CVE-2016-11086/"}