# CVE-2016-11086: Improper Certificate Validation in oauth ruby gem

> Man-in-the-middle attackers can spoof servers and obtain sensitive information due to missing X.509 certificate verification in the oauth-ruby gem.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2020
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-11086, GHSA-7359-3c6r-hfc2, UBUNTU-CVE-2016-11086

## What is CVE-2016-11086?

CVE-2016-11086 is a high-severity vulnerability in n/a, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2016-11086?

2 open source packages ship an affected version, including oauth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `oauth` | RubyGems | All versions | 0.5.5 |
| `oauth` | RubyGems | All versions | 0.5.5 |

Products: Oauth-Ruby Project Oauth-Ruby.

## How do I fix CVE-2016-11086?

Upgrade oauth to 0.5.5 or later.

## Is CVE-2016-11086 being exploited?

There is no known exploitation of CVE-2016-11086 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-11086 and fix it if it is affected.

What it is: CVE-2016-11086 is a high-severity vulnerability in n/a, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-11086 in the wild and no public exploit code.

Affected packages and fixed versions:
- oauth (RubyGems): affected all versions; fixed in 0.5.5
- oauth (RubyGems): affected all versions; fixed in 0.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-11086/ (Markdown: https://insights.sbomify.com/CVE-2016-11086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-11086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-11086
- OSV: https://osv.dev/vulnerability/CVE-2016-11086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-11086/
Summaries are generated and may contain mistakes; the official description above is the record.
