{"answers":{"affected":"2 open source packages ship an affected version, including electron. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-1202 in the wild and no public exploit code.","fix":"Upgrade electron to 0.33.5 or later.","what":"CVE-2016-1202 is a high-severity code injection vulnerability in n/a, published on 25 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-1202 and fix it if it is affected.\n\nWhat it is: CVE-2016-1202 is a high-severity code injection vulnerability in n/a, published on 25 Apr 2016. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-1202 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- electron (npm): affected all versions; fixed in 0.33.5\n- electron (npm): affected all versions; fixed in 0.33.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-1202/ (Markdown: https://insights.sbomify.com/CVE-2016-1202/index.md)","id":"CVE-2016-1202","markdown":"https://insights.sbomify.com/CVE-2016-1202/index.md","name":"CVE-2016-1202","record":{"aliases":["GHSA-gvcj-pfq2-wxj7"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Electron framework","requires_auth":"low_privilege","summary":"Local attackers can execute arbitrary code and escalate privileges by placing a malicious Node.js module in a parent directory.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"electron","vendor":"atom"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Untrusted search path vulnerability in Atom Electron before 0.33.5 allows local users to gain privileges via a Trojan horse Node.js module in a parent directory of a directory named on a require line.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"High severity vulnerability that affects electron","id":"CVE-2016-1202","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2016"},"n_packages":2,"n_references":4,"next":{"headline":"Code injection in SaAT Netizen","id":"CVE-2016-1203"},"packages":[{"ecosystem":"npm","fixed":["0.33.5"],"introduced":["0"],"last_affected":[],"package":"electron","purl":null,"source":"GHSA-gvcj-pfq2-wxj7"},{"ecosystem":"npm","fixed":["0.33.5"],"introduced":["0"],"last_affected":[],"package":"electron","purl":"pkg:npm/electron","source":"GHSA-gvcj-pfq2-wxj7"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2016-1201"},"products":["n/a"],"published":"2016-04-25","related":[{"cvss_score":8.8,"headline":"Remote Code Execution in electron","id":"CVE-2018-1000006","kev_date_added":null,"published":"2018-01-24"},{"cvss_score":4.3,"headline":"Electron vulnerable to URL spoofing via PDFium","id":"CVE-2017-1000424","kev_date_added":null,"published":"2018-01-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Local attackers can execute arbitrary code and escalate privileges by placing a malicious Node.js module in a parent directory.","url":"https://insights.sbomify.com/CVE-2016-1202/"}