# CVE-2016-1241: Tryton allows users to read the hashed password

> Remote authenticated users can discover user password hashes in Tryton, exposing sensitive credential data.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1241, GHSA-52j9-v3jc-9xgc, PYSEC-2016-12, PYSEC-2016-40, UBUNTU-CVE-2016-1241

## What is CVE-2016-1241?

CVE-2016-1241 is a medium-severity vulnerability in n/a, published on 7 Sep 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Tryton 3.x before 3.2.17, 3.4.x before 3.4.14, 3.6.x before 3.6.12, 3.8.x before 3.8.8, and 4.x before 4.0.4 allow remote authenticated users to discover user password hashes via unspecified vectors.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2016-1241?

12 open source packages ship an affected version, including trytond and tryton. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trytond` | PyPI | All versions | 3.2.17, 3.4.14, 3.6.12, 3.8.8, 4.0.4 |
| `trytond` | PyPI | From 3.0.0 | 3.2.17 |
| `trytond` | PyPI | From 3.0.0 | 3.2.17 |
| `trytond` | PyPI | From 3.4.0 | 3.4.14 |
| `trytond` | PyPI | From 3.4.0 | 3.4.14 |
| `trytond` | PyPI | From 3.6.0 | 3.6.12 |
| `trytond` | PyPI | From 3.6.0 | 3.6.12 |
| `trytond` | PyPI | From 3.8.0 | 3.8.8 |
| `trytond` | PyPI | From 3.8.0 | 3.8.8 |
| `trytond` | PyPI | From 4.0.0 | 4.0.4 |
| `trytond` | PyPI | From 4.0.0 | 4.0.4 |
| `tryton` | PyPI | All versions | 3.2.17 |

Products: Tryton Tryton.

## How do I fix CVE-2016-1241?

Upgrade trytond to a fixed version for your release line: 3.2.17, 3.4.14, 3.6.12 or 3.8.8.

## Is CVE-2016-1241 being exploited?

There is no known exploitation of CVE-2016-1241 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-6633](https://insights.sbomify.com/CVE-2014-6633/): Tryton vulnerable to arbitrary command execution (high 8.8)
- [CVE-2013-4510](https://insights.sbomify.com/CVE-2013-4510/): Tryton Directory Traversal vulnerability (high 7.8)
- [CVE-2018-19443](https://insights.sbomify.com/CVE-2018-19443/): Session Fixation in Tryton (medium 5.9)
- [CVE-2017-0360](https://insights.sbomify.com/CVE-2017-0360/): Tryton Information Disclosure Vulnerability (medium 5.3)
- [CVE-2016-1242](https://insights.sbomify.com/CVE-2016-1242/): Tryton allow authenticated users with certain permissions to read arbitrary files via the name parameter (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1241 and fix it if it is affected.

What it is: CVE-2016-1241 is a medium-severity vulnerability in n/a, published on 7 Sep 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1241 in the wild and no public exploit code.

Affected packages and fixed versions:
- trytond (PyPI): affected all versions; fixed in 3.2.17, 3.4.14, 3.6.12, 3.8.8, 4.0.4
- trytond (PyPI): affected from 3.0.0; fixed in 3.2.17
- trytond (PyPI): affected from 3.0.0; fixed in 3.2.17
- trytond (PyPI): affected from 3.4.0; fixed in 3.4.14
- trytond (PyPI): affected from 3.4.0; fixed in 3.4.14
- trytond (PyPI): affected from 3.6.0; fixed in 3.6.12
- trytond (PyPI): affected from 3.6.0; fixed in 3.6.12
- trytond (PyPI): affected from 3.8.0; fixed in 3.8.8
- trytond (PyPI): affected from 3.8.0; fixed in 3.8.8
- trytond (PyPI): affected from 4.0.0; fixed in 4.0.4
- trytond (PyPI): affected from 4.0.0; fixed in 4.0.4
- tryton (PyPI): affected all versions; fixed in 3.2.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1241/ (Markdown: https://insights.sbomify.com/CVE-2016-1241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1241
- OSV: https://osv.dev/vulnerability/CVE-2016-1241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1241/
Summaries are generated and may contain mistakes; the official description above is the record.
