{"answers":{"affected":"3 open source packages ship an affected version, including rsa. It affects 4 products.","exploited":"There is no known exploitation of CVE-2016-1494 in the wild and no public exploit code.","fix":"Upgrade rsa to 3.3 or later.","what":"CVE-2016-1494 is a medium-severity vulnerability in Fedoraproject Fedora, published on 13 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-1494 and fix it if it is affected.\n\nWhat it is: CVE-2016-1494 is a medium-severity vulnerability in Fedoraproject Fedora, published on 13 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-1494 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rsa (PyPI): affected all versions; fixed in 3.3\n- rsa (PyPI): affected all versions; fixed in 3.3\n- rsa (PyPI): affected all versions; fixed in 3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-1494/ (Markdown: https://insights.sbomify.com/CVE-2016-1494/index.md)","id":"CVE-2016-1494","markdown":"https://insights.sbomify.com/CVE-2016-1494/index.md","name":"CVE-2016-1494","record":{"aliases":["DEBIAN-CVE-2016-1494","GHSA-8rjr-6qq5-pj9p","MGASA-2016-0011","PYSEC-2016-10","SUSE-SU-2016:0107-1","UBUNTU-CVE-2016-1494"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python RSA library","requires_auth":"none","summary":"Attackers can spoof RSA signatures using crafted padding with small public exponents, bypassing signature verification in the Python-RSA library.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"leap","vendor":"opensuse"},{"product":"opensuse","vendor":"opensuse"},{"product":"rsa","vendor":"python"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.","ecosystems":["PyPI","SUSE:Linux Enterprise Module for Public Cloud 12"],"exploits":{"exploitdb":0,"first_seen":"2016-12-02","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2016-12-02T09:32:02Z","kind":"github_poc","ref":"https://github.com/matthiasbe/secuimag3a","stars":1,"title":"Exploit of the CVE-2016-1494 allowing to forge signatures of RSA keys with low exponents"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Python RSA allows attackers to spoof signatures","id":"CVE-2016-1494","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora","opensuse:leap","opensuse:opensuse"],"type":"other","year":"2016"},"n_packages":4,"n_references":8,"next":{"headline":"Integer overflow in n/a","id":"CVE-2016-1495"},"packages":[{"ecosystem":"PyPI","fixed":["3.3"],"introduced":["0"],"last_affected":[],"package":"rsa","purl":null,"source":"GHSA-8rjr-6qq5-pj9p"},{"ecosystem":"PyPI","fixed":["3.3"],"introduced":["0"],"last_affected":[],"package":"rsa","purl":"pkg:pypi/rsa","source":"GHSA-8rjr-6qq5-pj9p"},{"ecosystem":"PyPI","fixed":["3.3"],"introduced":["0"],"last_affected":[],"package":"rsa","purl":"pkg:pypi/rsa","source":"PYSEC-2016-10"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 12","fixed":["3.1.4-11.1"],"introduced":["0"],"last_affected":[],"package":"python-rsa","purl":"pkg:rpm/suse/python-rsa\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2012","source":"SUSE-SU-2016:0107-1"}],"prev":{"headline":"Other in n/a","id":"CVE-2016-1493"},"products":["n/a"],"published":"2016-01-13","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can spoof RSA signatures using crafted padding with small public exponents, bypassing signature verification in the Python-RSA library.","url":"https://insights.sbomify.com/CVE-2016-1494/"}