# CVE-2016-1494: Python RSA allows attackers to spoof signatures

> Attackers can spoof RSA signatures using crafted padding with small public exponents, bypassing signature verification in the Python-RSA library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jan 2016
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-1494, GHSA-8rjr-6qq5-pj9p, MGASA-2016-0011, PYSEC-2016-10, SUSE-SU-2016:0107-1, UBUNTU-CVE-2016-1494

## What is CVE-2016-1494?

CVE-2016-1494 is a medium-severity vulnerability in Fedoraproject Fedora, published on 13 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-1494?

3 open source packages ship an affected version, including rsa. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rsa` | PyPI | All versions | 3.3 |
| `rsa` | PyPI | All versions | 3.3 |
| `rsa` | PyPI | All versions | 3.3 |
| `python-rsa` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 3.1.4-11.1 |

Products: Fedoraproject Fedora, Opensuse Leap, Opensuse Opensuse, Python Rsa.

## How do I fix CVE-2016-1494?

Upgrade rsa to 3.3 or later.

## Is CVE-2016-1494 being exploited?

There is no known exploitation of CVE-2016-1494 in the wild and no public exploit code.

Public exploit code:

- Exploit of the CVE-2016-1494 allowing to forge signatures of RSA keys with low exponents (github_poc): https://github.com/matthiasbe/secuimag3a

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-1494 and fix it if it is affected.

What it is: CVE-2016-1494 is a medium-severity vulnerability in Fedoraproject Fedora, published on 13 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-1494 in the wild and no public exploit code.

Affected packages and fixed versions:
- rsa (PyPI): affected all versions; fixed in 3.3
- rsa (PyPI): affected all versions; fixed in 3.3
- rsa (PyPI): affected all versions; fixed in 3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-1494/ (Markdown: https://insights.sbomify.com/CVE-2016-1494/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-1494
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-1494
- OSV: https://osv.dev/vulnerability/CVE-2016-1494

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-1494/
Summaries are generated and may contain mistakes; the official description above is the record.
