CVE-2016-15004 InfiniteWP Client Plugin injection
Remote attackers can execute arbitrary code via injection in the InfiniteWP Client Plugin, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2016-15004?
CVE-2016-15004 is a high-severity code injection vulnerability in unspecified InfiniteWP Client Plugin, published on 23 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability was found in InfiniteWP Client Plugin 1.5.1.3/1.6.0. It has been declared as critical. Affected by this vulnerability is an unknown functionality. The manipulation leads to injection. The attack can be launched remotely. Upgrading to version 1.6.1.1 is able to address this issue. It is recommended to upgrade the affected component.
Weakness: CWE-74
Which versions are affected by CVE-2016-15004?
It affects 1 product.
Products include Revmakx Infinitewp Client.
How do I fix CVE-2016-15004?
No fix has been published for CVE-2016-15004 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2016-15004 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-15004 exists.
Other vulnerabilities in unspecified InfiniteWP Client Plugin
- CVE-2020-8772 Missing authorization in n/a
- CVE-2023-2916 InfiniteWP Client <= 1.11.1 - Authenticated (Subscriber+) Sensitive Information Exposure
- CVE-2023-6565 InfiniteWP Client <= 1.12.3 - Unauthenticated Sensitive Information Exposure
- CVE-2024-10585 InfiniteWP Client <= 1.13.0 - Unauthenticated Limited Directory Traversal to Arbitrary .txt File Reading
Sources
Also known as GHSA-6645-42mw-qcmm.