# CVE-2016-15004: InfiniteWP Client Plugin injection

> Remote attackers can execute arbitrary code via injection in the InfiniteWP Client Plugin, requiring an upgrade to mitigate.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jul 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-6645-42mw-qcmm

## What is CVE-2016-15004?

CVE-2016-15004 is a high-severity code injection vulnerability in unspecified InfiniteWP Client Plugin, published on 23 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in InfiniteWP Client Plugin 1.5.1.3/1.6.0. It has been declared as critical. Affected by this vulnerability is an unknown functionality. The manipulation leads to injection. The attack can be launched remotely. Upgrading to version 1.6.1.1 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2016-15004?

It affects 1 product.


Products: Revmakx Infinitewp Client.

## How do I fix CVE-2016-15004?

No fix has been published for CVE-2016-15004 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-15004 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-15004 exists.

## Other vulnerabilities in unspecified InfiniteWP Client Plugin

- [CVE-2020-8772](https://insights.sbomify.com/CVE-2020-8772/): Missing authorization in n/a (critical 9.8)
- [CVE-2023-2916](https://insights.sbomify.com/CVE-2023-2916/): InfiniteWP Client <= 1.11.1 - Authenticated (Subscriber+) Sensitive Information Exposure (high 7.5)
- [CVE-2023-6565](https://insights.sbomify.com/CVE-2023-6565/): InfiniteWP Client <= 1.12.3 - Unauthenticated Sensitive Information Exposure (medium 5.9)
- [CVE-2024-10585](https://insights.sbomify.com/CVE-2024-10585/): InfiniteWP Client <= 1.13.0 - Unauthenticated Limited Directory Traversal to Arbitrary .txt File Reading (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15004 and fix it if it is affected.

What it is: CVE-2016-15004 is a high-severity code injection vulnerability in unspecified InfiniteWP Client Plugin, published on 23 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-15004 exists.

Affected product: unspecified InfiniteWP Client Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15004/ (Markdown: https://insights.sbomify.com/CVE-2016-15004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15004
- OSV: https://osv.dev/vulnerability/CVE-2016-15004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15004/
Summaries are generated and may contain mistakes; the official description above is the record.
