{"answers":{"affected":"3 open source packages ship an affected version, including django-ucamlookup. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15010 in the wild and no public exploit code.","fix":"Upgrade django-ucamlookup to 1.9.2 or later.","what":"CVE-2016-15010 is a low-severity vulnerability in University of Cambridge django-ucamlookup, published on 5 Jan 2023."},"fix_prompt":"Check this codebase for CVE-2016-15010 and fix it if it is affected.\n\nWhat it is: CVE-2016-15010 is a low-severity vulnerability in University of Cambridge django-ucamlookup, published on 5 Jan 2023. \nExploitation: There is no known exploitation of CVE-2016-15010 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django-ucamlookup (PyPI): affected all versions; fixed in 1.9.2\n- django-ucamlookup (PyPI): affected all versions; fixed in 1.9.2\n- django-ucamlookup (PyPI): affected all versions; fixed in 1.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15010/ (Markdown: https://insights.sbomify.com/CVE-2016-15010/index.md)","id":"CVE-2016-15010","markdown":"https://insights.sbomify.com/CVE-2016-15010/index.md","name":"CVE-2016-15010","record":{"aliases":["GHSA-pjx4-3f3p-29v3","PYSEC-2023-14"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"django-ucamlookup","vendor":"django-ucamlookup_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic was found in University of Cambridge django-ucamlookup up to 1.9.1. Affected by this vulnerability is an unknown functionality of the component Lookup Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.9.2 is able to address this issue. The identifier of the patch is 5e25e4765637ea4b9e0bf5fcd5e9a922abee7eb3. It is recommended to upgrade the affected component. The identifier VDB-217441 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"University of Cambridge django-ucamlookup Lookup cross site scripting","id":"CVE-2016-15010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2016"},"n_packages":3,"n_references":4,"next":{"headline":"e-Contract dssp SignResponseVerifier.java checkSignResponse xml external entity reference","id":"CVE-2016-15011"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"django-ucamlookup","purl":null,"source":"GHSA-pjx4-3f3p-29v3"},{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"django-ucamlookup","purl":"pkg:pypi/django-ucamlookup","source":"GHSA-pjx4-3f3p-29v3"},{"ecosystem":"PyPI","fixed":["1.9.2"],"introduced":["0"],"last_affected":[],"package":"django-ucamlookup","purl":"pkg:pypi/django-ucamlookup","source":"PYSEC-2023-14"}],"prev":{"headline":"OpenACS bug-tracker Search nav-bar.adp cross-site request forgery","id":"CVE-2016-15009"},"products":["django-ucamlookup"],"published":"2023-01-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["University of Cambridge"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2016-15010/"}