# CVE-2016-15010: University of Cambridge django-ucamlookup Lookup cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-pjx4-3f3p-29v3, PYSEC-2023-14

## What is CVE-2016-15010?

CVE-2016-15010 is a low-severity vulnerability in University of Cambridge django-ucamlookup, published on 5 Jan 2023. 

### Official description

** UNSUPPORTED WHEN ASSIGNED ** A vulnerability classified as problematic was found in University of Cambridge django-ucamlookup up to 1.9.1. Affected by this vulnerability is an unknown functionality of the component Lookup Handler. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.9.2 is able to address this issue. The identifier of the patch is 5e25e4765637ea4b9e0bf5fcd5e9a922abee7eb3. It is recommended to upgrade the affected component. The identifier VDB-217441 was assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-15010?

3 open source packages ship an affected version, including django-ucamlookup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-ucamlookup` | PyPI | All versions | 1.9.2 |
| `django-ucamlookup` | PyPI | All versions | 1.9.2 |
| `django-ucamlookup` | PyPI | All versions | 1.9.2 |

Products: Django-Ucamlookup Project Django-Ucamlookup.

## How do I fix CVE-2016-15010?

Upgrade django-ucamlookup to 1.9.2 or later.

## Is CVE-2016-15010 being exploited?

There is no known exploitation of CVE-2016-15010 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15010 and fix it if it is affected.

What it is: CVE-2016-15010 is a low-severity vulnerability in University of Cambridge django-ucamlookup, published on 5 Jan 2023. 
Exploitation: There is no known exploitation of CVE-2016-15010 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-ucamlookup (PyPI): affected all versions; fixed in 1.9.2
- django-ucamlookup (PyPI): affected all versions; fixed in 1.9.2
- django-ucamlookup (PyPI): affected all versions; fixed in 1.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15010/ (Markdown: https://insights.sbomify.com/CVE-2016-15010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15010
- OSV: https://osv.dev/vulnerability/CVE-2016-15010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15010/
Summaries are generated and may contain mistakes; the official description above is the record.
