{"answers":{"affected":"2 open source packages ship an affected version, including be.e_contract.dssp:dssp-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15011 in the wild and no public exploit code.","fix":"Upgrade be.e_contract.dssp:dssp-client to 1.3.2 or later.","what":"CVE-2016-15011 is a medium-severity vulnerability in e-Contract dssp, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-15011 and fix it if it is affected.\n\nWhat it is: CVE-2016-15011 is a medium-severity vulnerability in e-Contract dssp, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-15011 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- be.e_contract.dssp:dssp-client (Maven): affected all versions; fixed in 1.3.2\n- be.e_contract.dssp:dssp-client (Maven): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15011/ (Markdown: https://insights.sbomify.com/CVE-2016-15011/index.md)","id":"CVE-2016-15011","markdown":"https://insights.sbomify.com/CVE-2016-15011/index.md","name":"CVE-2016-15011","record":{"aliases":["GHSA-77cc-w3wm-6whp"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java DSSP library","requires_auth":"low_privilege","summary":"An attacker can exploit XML External Entity injection in the SignResponseVerifier to read sensitive data or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"dssp","vendor":"e-contract"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"A vulnerability classified as problematic was found in e-Contract dssp up to 1.3.1. Affected by this vulnerability is the function checkSignResponse of the file dssp-client/src/main/java/be/e_contract/dssp/client/SignResponseVerifier.java. The manipulation leads to xml external entity reference. Upgrading to version 1.3.2 is able to address this issue. The identifier of the patch is ec4238349691ec66dd30b416ec6eaab02d722302. It is recommended to upgrade the affected component. The identifier VDB-217549 was assigned to this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"e-Contract dssp SignResponseVerifier.java checkSignResponse xml external entity reference","id":"CVE-2016-15011","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2016"},"n_packages":2,"n_references":4,"next":{"headline":"forcedotcom SalesforceMobileSDK-Windows QuerySpec.cs ComputeCountSql sql injection","id":"CVE-2016-15012"},"packages":[{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"be.e_contract.dssp:dssp-client","purl":null,"source":"GHSA-77cc-w3wm-6whp"},{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"be.e_contract.dssp:dssp-client","purl":"pkg:maven/be.e_contract.dssp/dssp-client","source":"GHSA-77cc-w3wm-6whp"}],"prev":{"headline":"University of Cambridge django-ucamlookup Lookup cross site scripting","id":"CVE-2016-15010"},"products":["dssp"],"published":"2023-01-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["e-Contract"]},"summary":"An attacker can exploit XML External Entity injection in the SignResponseVerifier to read sensitive data or cause denial of service.","url":"https://insights.sbomify.com/CVE-2016-15011/"}