# CVE-2016-15011: e-Contract dssp SignResponseVerifier.java checkSignResponse xml external entity reference

> An attacker can exploit XML External Entity injection in the SignResponseVerifier to read sensitive data or cause denial of service.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-77cc-w3wm-6whp

## What is CVE-2016-15011?

CVE-2016-15011 is a medium-severity vulnerability in e-Contract dssp, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as problematic was found in e-Contract dssp up to 1.3.1. Affected by this vulnerability is the function checkSignResponse of the file dssp-client/src/main/java/be/e_contract/dssp/client/SignResponseVerifier.java. The manipulation leads to xml external entity reference. Upgrading to version 1.3.2 is able to address this issue. The identifier of the patch is ec4238349691ec66dd30b416ec6eaab02d722302. It is recommended to upgrade the affected component. The identifier VDB-217549 was assigned to this vulnerability.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2016-15011?

2 open source packages ship an affected version, including be.e_contract.dssp:dssp-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `be.e_contract.dssp:dssp-client` | Maven | All versions | 1.3.2 |
| `be.e_contract.dssp:dssp-client` | Maven | All versions | 1.3.2 |

Products: E-Contract Dssp.

## How do I fix CVE-2016-15011?

Upgrade be.e_contract.dssp:dssp-client to 1.3.2 or later.

## Is CVE-2016-15011 being exploited?

There is no known exploitation of CVE-2016-15011 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15011 and fix it if it is affected.

What it is: CVE-2016-15011 is a medium-severity vulnerability in e-Contract dssp, published on 6 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-15011 in the wild and no public exploit code.

Affected packages and fixed versions:
- be.e_contract.dssp:dssp-client (Maven): affected all versions; fixed in 1.3.2
- be.e_contract.dssp:dssp-client (Maven): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15011/ (Markdown: https://insights.sbomify.com/CVE-2016-15011/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15011
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15011
- OSV: https://osv.dev/vulnerability/CVE-2016-15011

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15011/
Summaries are generated and may contain mistakes; the official description above is the record.
