CVE-2016-15015 viafintech Barzahlen Payment Module PHP SDK Webhook.php verify timing discrepancy

Low 2.6 Published Updated

An attacker can exploit timing discrepancies in webhook verification to potentially bypass signature checks in the Barzahlen Payment Module PHP SDK.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2016-15015?

CVE-2016-15015 is a low-severity vulnerability in viafintech Barzahlen Payment Module PHP SDK, published on 8 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability, which was classified as problematic, was found in viafintech Barzahlen Payment Module PHP SDK up to 2.0.0. Affected is the function verify of the file src/Webhook.php. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 2.0.1 is able to address this issue. The patch is identified as 3e7d29dc0ca6c054a6d6e211f32dae89078594c1. It is recommended to upgrade the affected component. VDB-217650 is the identifier assigned to this vulnerability.

Weakness: CWE-203, CWE-208

Which versions are affected by CVE-2016-15015?

2 open source packages ship an affected version, including barzahlen/barzahlen-php. It affects 1 product.

PackageAffectedFixed in
barzahlen/barzahlen-php PackagistAll versions2.0.1
barzahlen/barzahlen-php PackagistAll versions2.0.1

Products include Paysafe Barzahlen Payment Module Php Sdk.

How do I fix CVE-2016-15015?

Upgrade barzahlen/barzahlen-php to 2.0.1 or later.

Is CVE-2016-15015 being exploited?

There is no known exploitation of CVE-2016-15015 in the wild and no public exploit code.

Sources

Also known as GHSA-vg5x-6q66-rvgx.

Is CVE-2016-15015 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free