CVE-2016-15018 krail-jpa sql injection

Medium 5.5 Published Updated

An attacker can execute arbitrary SQL commands via the krail-jpa library, potentially reading or modifying database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2016-15018?

CVE-2016-15018 is a medium-severity SQL injection vulnerability in krail-jpa, published on 15 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in krail-jpa up to 0.9.1. It has been classified as critical. This affects an unknown part. The manipulation leads to sql injection. Upgrading to version 0.9.2 is able to address this issue. The identifier of the patch is c1e848665492e21ef6cc9be443205e36b9a1f6be. It is recommended to upgrade the affected component. The identifier VDB-218373 was assigned to this vulnerability.

Weakness: CWE-89

Which versions are affected by CVE-2016-15018?

It affects 1 product.

Products include Krail-Jpa Project Krail-Jpa.

How do I fix CVE-2016-15018?

No fix has been published for CVE-2016-15018 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2016-15018 being exploited?

There is no known exploitation of CVE-2016-15018 in the wild and no public exploit code.

Sources

Also known as GHSA-p2c4-5gxh-4qv6.

Is CVE-2016-15018 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free