# CVE-2016-15018: krail-jpa sql injection

> An attacker can execute arbitrary SQL commands via the krail-jpa library, potentially reading or modifying database contents.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p2c4-5gxh-4qv6

## What is CVE-2016-15018?

CVE-2016-15018 is a medium-severity SQL injection vulnerability in krail-jpa, published on 15 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in krail-jpa up to 0.9.1. It has been classified as critical. This affects an unknown part. The manipulation leads to sql injection. Upgrading to version 0.9.2 is able to address this issue. The identifier of the patch is c1e848665492e21ef6cc9be443205e36b9a1f6be. It is recommended to upgrade the affected component. The identifier VDB-218373 was assigned to this vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-15018?

It affects 1 product.


Products: Krail-Jpa Project Krail-Jpa.

## How do I fix CVE-2016-15018?

No fix has been published for CVE-2016-15018 yet. Limit exposure of the affected software until one is available.

## Is CVE-2016-15018 being exploited?

There is no known exploitation of CVE-2016-15018 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15018 and fix it if it is affected.

What it is: CVE-2016-15018 is a medium-severity SQL injection vulnerability in krail-jpa, published on 15 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-15018 in the wild and no public exploit code.

Affected product: krail-jpa. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15018/ (Markdown: https://insights.sbomify.com/CVE-2016-15018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15018
- OSV: https://osv.dev/vulnerability/CVE-2016-15018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15018/
Summaries are generated and may contain mistakes; the official description above is the record.
