CVE-2016-15020 liftkit database Query.php processOrderBy sql injection

Medium 5.5 Published Updated

An attacker can perform SQL injection via the processOrderBy function in the liftkit database library, potentially reading or modifying data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2016-15020?

CVE-2016-15020 is a medium-severity SQL injection vulnerability in liftkit database, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The patch is named 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.

Weakness: CWE-89

Which versions are affected by CVE-2016-15020?

2 open source packages ship an affected version, including liftkit/database. It affects 1 product.

PackageAffectedFixed in
liftkit/database PackagistAll versions2.13.2
liftkit/database PackagistAll versions2.13.2

Products include Liftkit Database Library Project Liftkit Database Library.

How do I fix CVE-2016-15020?

Upgrade liftkit/database to 2.13.2 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2016-15020 being exploited?

There is no known exploitation of CVE-2016-15020 in the wild and no public exploit code.

Sources

Also known as GHSA-8hcf-2m4v-f2rq.

Is CVE-2016-15020 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free