{"answers":{"affected":"2 open source packages ship an affected version, including liftkit/database. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-15020 in the wild and no public exploit code.","fix":"Upgrade liftkit/database to 2.13.2 or later.","what":"CVE-2016-15020 is a medium-severity SQL injection vulnerability in liftkit database, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-15020 and fix it if it is affected.\n\nWhat it is: CVE-2016-15020 is a medium-severity SQL injection vulnerability in liftkit database, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-15020 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- liftkit/database (Packagist): affected all versions; fixed in 2.13.2\n- liftkit/database (Packagist): affected all versions; fixed in 2.13.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-15020/ (Markdown: https://insights.sbomify.com/CVE-2016-15020/index.md)","id":"CVE-2016-15020","markdown":"https://insights.sbomify.com/CVE-2016-15020/index.md","name":"CVE-2016-15020","record":{"aliases":["GHSA-8hcf-2m4v-f2rq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PHP database library","requires_auth":"low_privilege","summary":"An attacker can perform SQL injection via the processOrderBy function in the liftkit database library, potentially reading or modifying data.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"liftkit_database_library","vendor":"liftkit_database_library_project"}],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The patch is named 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"liftkit database Query.php processOrderBy sql injection","id":"CVE-2016-15020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2016"},"n_packages":2,"n_references":4,"next":{"headline":"nickzren alsdb sql injection","id":"CVE-2016-15021"},"packages":[{"ecosystem":"Packagist","fixed":["2.13.2"],"introduced":["0"],"last_affected":[],"package":"liftkit/database","purl":null,"source":"GHSA-8hcf-2m4v-f2rq"},{"ecosystem":"Packagist","fixed":["2.13.2"],"introduced":["0"],"last_affected":[],"package":"liftkit/database","purl":"pkg:composer/liftkit/database","source":"GHSA-8hcf-2m4v-f2rq"}],"prev":{"headline":"tombh jekbox server.rb exposure of information through directory listing","id":"CVE-2016-15019"},"products":["database"],"published":"2023-01-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-06","vendors":["liftkit"]},"summary":"An attacker can perform SQL injection via the processOrderBy function in the liftkit database library, potentially reading or modifying data.","url":"https://insights.sbomify.com/CVE-2016-15020/"}