# CVE-2016-15020: liftkit database Query.php processOrderBy sql injection

> An attacker can perform SQL injection via the processOrderBy function in the liftkit database library, potentially reading or modifying data.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jan 2023
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-8hcf-2m4v-f2rq

## What is CVE-2016-15020?

CVE-2016-15020 is a medium-severity SQL injection vulnerability in liftkit database, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The patch is named 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-15020?

2 open source packages ship an affected version, including liftkit/database. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `liftkit/database` | Packagist | All versions | 2.13.2 |
| `liftkit/database` | Packagist | All versions | 2.13.2 |

Products: Liftkit Database Library Project Liftkit Database Library.

## How do I fix CVE-2016-15020?

Upgrade liftkit/database to 2.13.2 or later.

## Is CVE-2016-15020 being exploited?

There is no known exploitation of CVE-2016-15020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-15020 and fix it if it is affected.

What it is: CVE-2016-15020 is a medium-severity SQL injection vulnerability in liftkit database, published on 16 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-15020 in the wild and no public exploit code.

Affected packages and fixed versions:
- liftkit/database (Packagist): affected all versions; fixed in 2.13.2
- liftkit/database (Packagist): affected all versions; fixed in 2.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-15020/ (Markdown: https://insights.sbomify.com/CVE-2016-15020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-15020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-15020
- OSV: https://osv.dev/vulnerability/CVE-2016-15020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-15020/
Summaries are generated and may contain mistakes; the official description above is the record.
